代写公式指标 代写指标股票公式定制开发

时间:2024-07-09  来源:  作者: 我要纠错


空方力度:=100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55));
多方力度:=(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1));
RSV:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;
M:=55;N:=34;LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE-LC),0),3,1)/SMA(ABS((CLOSE-LC)),3,1))*100);FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);DRAWICON(CROSS(88.8,RSI),90,15);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);VAR3:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;VAR5:=FILTER((趋势<=13 AND VAR4>13),10);VAR6:=FILTER((趋势>=90 AND VAR4),10);VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;VAR11:=SMA(ABS(LOW-REF(LOW,1)),3,1)/SMA(MAX(LOW-REF(LOW,1),0),3,1);
VAR12:=HHV(VAR11,30)*8;VAR2222:=REF(LOW,1);VAR3333:=(SMA(ABS(LOW-VAR2222),3,1))/(SMA(MAX(LOW-VAR2222,0),3,1))*100;VAR4444:=EMA(IF(CLOSE*1.3,VAR3333*10,VAR3333/10),3);
VAR5555:=LLV(LOW,30);VAR6666:=HHV(VAR4444,30);VAR7777:=IF(MA(CLOSE,58),1,0);主力吸筹:(EMA(IF(LOW<=VAR5555,(VAR4444+VAR6666*2)/2,0),3))/(618)*VAR7777,COLORYELLOW,NODRAW;
VAR9999:=IF(主力吸筹>100,100,主力吸筹);A5:=((CLOSE-(LLV(LOW,9)))/((HHV(HIGH,9))-(LLV(LOW,9))))*100;A6:=SMA(A5,3,1);A7:=SMA(A6,3,1);A17:=MA(CLOSE,90);A26:=((CLOSE-A17)/A17)*100;
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K2:=SMA(RSV2,3,1);D2:=SMA(K2,3,1);A65:=(CROSS(K2,D2))*60;A105:=MA(CLOSE,27);A106:=((CLOSE-A105)/A105)*100;A107:=(MA(A106,3));
A149:=BARSLAST(((CROSS(-10,A107))=1));A150:=BARSLAST(((CROSS(A107,10))=1));A151:=((A107<-10) AND (A149>3));A152:=((A107>10) AND (A150>3));赶快出手:0,COLORRED,DOTLINE,NODRAW;
NOTEXT底:0,DOTLINE,COLORGRAY;安全:=(((IF(A151,A107,0))<0)*-10),COLORGREEN;STICKLINE(VAR9999>-150,0,VAR9999*0.33,0,1),COLORYELLOW;STICKLINE(VAR9999>-150,0,VAR9999*0.33,3.2,0),COLOR117777;
STICKLINE(VAR9999>-150,0,VAR9999*0.33,2.0,0),COLOR119999;STICKLINE(VAR9999>-150,0,VAR9999*0.33,1.0,0),COLOR11BBBB;STICKLINE(VAR9999>-150,0,VAR9999*0.33,0.2,0),COLOR11DDDD;
STICKLINE(VAR9999>-150,0,VAR9999*0.33,0.0,0),COLOR44FFFF;STICKLINE(CROSS(多方力度,6.78),33.33,0,3.2,0),COLOR000555;STICKLINE(CROSS(多方力度,6.78),33.33,0,2.8,0),COLOR000777;
STICKLINE(CROSS(多方力度,6.78),33.33,0,2.0,0),COLOR000999;STICKLINE(CROSS(多方力度,6.78),33.33,0,1.0,0),COLOR000BBB;STICKLINE(CROSS(多方力度,6.78),33.33,0,0.2,0),COLOR000DDD;
STICKLINE(CROSS(多方力度,6.78),33.33,0,0.0,0),COLOR000FFF;NOTEXT顶:90,DOTLINE,COLORLIBLUE;NOTEXT界:44,DOTLINE,COLORGRAY;多方强度大小:多方力度,COLORMAGENTA,LINETHICK2;
空方强度大小:空方力度,COLORLIGREEN,LINETHICK1;持股:=(IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL)),COLORRED,NODRAW;持币:=(IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL)),COLORCYAN,NODRAW;
STICKLINE(持股,43.98,44.02,2.1,0),COLORRED;STICKLINE(持币,43.98,44.02,2.1,0),COLORCYAN;今日保护价:(REF(C,2)+REF(C,1)+O)/3,COLORCYAN,NODRAW;

原理解析:

原理解析:
空方力度赋值:100*(55日内最高价最高值-收盘价)/(55日内最高价最高值-55日内最低价最低值)
多方力度赋值:(3*SMA((收盘价-27日内最低价最低值)/(27日内最高价最高值-27日内最低价最低值)*100,5,1)-2*SMA(SMA((收盘价-27日内最低价最低值)/(27日内最高价最高值-27日内最低价最低值)*100,5,1),3,1))
RSV赋值:(收盘价-30日内最低价最低值)/(30日内最高价最高值-30日内最低价最低值)*100
RSV的3日[1日权重]移动平均
K的3日[1日权重]移动平均
J赋值:3*K-2*D
M赋值:55
N赋值:34
LC赋值:1日前的收盘价
RSI赋值:((SMA(MAX((收盘价-LC),0),3,1)/SMA((收盘价-LC的绝对值),3,1))*100)
FF赋值:收盘价的3日指数移动平均
MA15:=收盘价的21日指数移动平均
DRAWICON(88.8上穿RSI,90,15)
VAR1赋值:3*SMA((收盘价-27日内最低价最低值)/(27日内最高价最高值-27日内最低价最低值)*100,5,1)-2*SMA(SMA((收盘价-27日内最低价最低值)/(27日内最高价最高值-27日内最低价最低值)*100,5,1),3,1)
VAR2赋值:VAR1的8日指数移动平均
VAR3赋值:3*SMA((收盘价-55日内最低价最低值)/(55日内最高价最高值-55日内最低价最低值)*100,5,1)-2*SMA(SMA((收盘价-55日内最低价最低值)/(55日内最高价最高值-55日内最低价最低值)*100,5,1),3,1)
趋势赋值:VAR3的3日指数移动平均-10
VAR4赋值:(趋势-1日前的趋势)/1日前的趋势*100
VAR5赋值:FILTER((趋势<=13 AND VAR4>13),10)
VAR6赋值:FILTER((趋势>=90 AND VAR4),10)
VAR7赋值:30日内最低价最低值
VAR8赋值:30日内最高价最高值
VAR9赋值:EMA((收盘价-VAR7)/(VAR8-VAR7)*4,4)*25
VAR10:=(VAR9-4日内VAR9最低值)/(4日内VAR9最高值-4日内VAR9最低值)*100
VAR11:=SMA(最低价-1日前的最低价的绝对值,3,1)/SMA(最低价-1日前的最低价和0较大值,3,1)
VAR12:=30日内VAR11最高值*8
VAR2222:=1日前的最低价
VAR3333:=(SMA(最低价-VAR2222的绝对值,3,1))/(SMA(最低价-VAR2222和0较大值,3,1))*100
如果收盘价*1.3返回VAR3333*10否则返回VAR3333/10
VAR5555:=30日内最低价最低值
VAR6666:=30日内VAR4444最高值
VAR7777:=IF(收盘价的58日简单移动平均,1,0)
输出主力吸筹:(EMA(IF(最低价<=VAR5555,(VAR4444+VAR6666*2)/2,0),3))/(618)*VAR7777,画黄色,NODRAW
如果主力吸筹>100返回100否则返回主力吸筹
A5赋值:((收盘价-(9日内最低价最低值))/((9日内最高价最高值)-(9日内最低价最低值)))*100
A5的3日[1日权重]移动平均
A6的3日[1日权重]移动平均
A17赋值:收盘价的90日简单移动平均
A26赋值:((收盘价-A17)/A17)*100
RSV2:=(收盘价-9日内最低价最低值)/(9日内最高价最高值-9日内最低价最低值)*100
RSV2的3日[1日权重]移动平均
K2的3日[1日权重]移动平均
A65:=(K2上穿D2)*60
A105赋值:收盘价的27日简单移动平均
A106赋值:((收盘价-A105)/A105)*100
A107赋值:(A106的3日简单移动平均)
A149赋值:上次((-10上穿A107距今天数=1))
A150赋值:上次((A107上穿10距今天数=1))
A151赋值:((A107<-10) AND (A149>3))
A152赋值:((A107>10) AND (A150>3))
输出赶快出手:0,COLORRED,DOTLINE,NODRAW
NOTEXT底:0,DOTLINE,COLORGRAY
如果A151返回A107否则返回0
当满足条件VAR9999>-150时,在0和VAR9999*0.33之间画柱状线
当满足条件VAR9999>-150时,在0和VAR9999*0.33之间画柱状线
当满足条件VAR9999>-150时,在0和VAR9999*0.33之间画柱状线
当满足条件VAR9999>-150时,在0和VAR9999*0.33之间画柱状线
当满足条件VAR9999>-150时,在0和VAR9999*0.33之间画柱状线
当满足条件VAR9999>-150时,在0和VAR9999*0.33之间画柱状线
STICKLINE(多方力度上穿6.78,33.33,0,3.2,0),COLOR000555
STICKLINE(多方力度上穿6.78,33.33,0,2.8,0),COLOR000777
STICKLINE(多方力度上穿6.78,33.33,0,2.0,0),COLOR000999
STICKLINE(多方力度上穿6.78,33.33,0,1.0,0),COLOR000BBB
STICKLINE(多方力度上穿6.78,33.33,0,0.2,0),COLOR000DDD
STICKLINE(多方力度上穿6.78,33.33,0,0.0,0),COLOR000FFF
NOTEXT顶:90,DOTLINE,COLORLIBLUE
NOTEXT界:44,DOTLINE,COLORGRAY
输出多方强度大小:多方力度,COLORMAGENTA,LINETHICK2
输出空方强度大小:空方力度,COLORLIGREEN,LINETHICK1
持股赋值:(IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL)),COLORRED,NODRAW
持币赋值:(IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL)),COLORCYAN,NODRAW
当满足条件持股时,在43.98和44.02之间画柱状线
当满足条件持币时,在43.98和44.02之间画柱状线
输出今日保护价:(2日前的C+1日前的C+O)/3,COLORCYAN,NODRAW



如有需要,请加QQ:88652583 或微信: 88652583






 

标签:

扫一扫在手机打开当前页
  • 上一篇:COMP9414代写、Python语言编程代做
  • 下一篇:返回列表
  • 无相关信息
    昆明生活资讯

    昆明图文信息
    蝴蝶泉(4A)-大理旅游
    蝴蝶泉(4A)-大理旅游
    油炸竹虫
    油炸竹虫
    酸笋煮鱼(鸡)
    酸笋煮鱼(鸡)
    竹筒饭
    竹筒饭
    香茅草烤鱼
    香茅草烤鱼
    柠檬烤鱼
    柠檬烤鱼
    昆明西山国家级风景名胜区
    昆明西山国家级风景名胜区
    昆明旅游索道攻略
    昆明旅游索道攻略
  • 关于我们 | 打赏支持 | 广告服务 | 联系我们 | 网站地图 | 免责声明 | 帮助中心 | 友情链接 |

    Copyright © 2023 kmw.cc Inc. All Rights Reserved. 昆明网 版权所有
    ICP备06013414号-3 公安备 42010502001045